Summary:
A user may encounter this error while trying to access the timesheet. This is a user profile configuration issue. 

Cause: 

  • The user’s Start Date is set to a future date. 
  • The Timesheet Period type is set to a type that is not defined or configured in Web TimeSheet.
  • The timesheet period set for the user has an effective date later than the date that the user is trying log time.
  • The timesheet period is associated with a department, and the users profile has no department selected. 
  • The timesheet period is associated with department, and the user’s primary department does not have a timesheet period type associated with it. 

Solution:

  • Log in as the Web TimeSheet Administrator. 
  • Click on the “Administration” icon at the top menu bar. 
  • Choose the “Users” option from the left panel, found below the “Users/Departments” category. 
  • Pick the “User” for whom the timesheet does not generate, by clicking on the “Edit” button (represented by the icon of a paper & pencil) adjacent to the User Name or highlight the User Name and then click on the “Edit” button at the bottom. The “Edit User” page appears. 
  • Click on the “Advanced” tab and under the “General” category; make sure an appropriate Timesheet Period Type is set for the user and the “Start Date” is set to be the current date or a past date. 
  • Choose the “Timesheet Periods” option from the left panel, found below the “Timesheet Setup” category. 
  • Ensure that the “Effective Date” of the “Timesheet Period Type” is set to be the current date or a past date.

Note:
When the Timesheet period type of a user is set to Department, Web TimeSheet always looks at the user’s Primary department and not the Additional/Secondary department.