Summary:
The following error occurs when a user tries to log on to the Web TimeSheet using an authentication type that is not defined in Web TimeSheet. The authentication mechanism is unknown.

Cause:
The usual scenarios when this error is noticed are listed below,

  • User is setup with the authentication type as SAML, but user tries to log into Web TimeSheet using internal Web TimeSheet login details.
  • User is setup for SAML authentication and is accessing the application outside the network via VPN.

Resolution:
If the authentication type is SAML and user is authenticating using VPN, the following steps should fix the issue:

  • Change the VPN Gateway. If the VPN client has only 1 gateway, disconnect VPN and reconnect.
  • Clear the browser cookies and cache.
  • Ensure that in the Web TimeSheet, the user profile has the Fully Qualified Domain name listed instead of the domain.

This can only be verified by a user that has administrative privileges or rights on the application. Please contact your Web TimeSheet administrator and request them to follow the below steps:

  • Log into Web TimeSheet with admin right. Click on 'System–>Administration'.
  • Click on 'Users', under Shortcuts' and locate the user experiencing the login error.
  • Double click on the profile. Under the Access tab, ensure that the 'Domain' field has the Fully Qualified Domain Name instead of only the domain name.
  • Make the changes and click on 'Save'.

Now when the user tries to log into Web TimeSheet with the right NT user name and NT password, the system should proceed with the authentication with no error messages.