Summary:
You may receive an error Time Cell has zero value in Web TimeSheet. No Time entries were transferred to QuickBooks while transferring time entries from Web TimeSheet to QuickBooks.

Cause:
QuickBooks does not recognize zero hour as a valid time entry. Hence, if a user has entered time against a Project/Task or an activity as '0', then QuickBooks will not allow this '0' hr entry to be updated.

Resolution:
You will need to edit the user timesheet whose time transfer failed with this error. Remove any zero entry found in any of the time cells on the affected timesheet period, and Save the timesheet. Now, you can do the time transfer, and it should work.