Symptoms:
An error message is thrown upon saving a user's profile and doesn't allow to save the user's internal e-mail address.
 
 
Cause:
This error occurs when the time off policy for PTO time off type or any time off type in Web TimeSheet, has the Balance set to Carry up to and the Carry up to day(s) or hour(s) is in a negative value. The function of 'Carry up to' is to carry the previous policy end balance to the new policy's starting balance, but only up to the limit you specify, so logically this limit cannot be a negative value since the system can only carry a positive value to the new policy.
 
Resolution:
  • Log into Web TimeSheet as the administrator.
  • Click the Administration icon at the top menu bar.
  • Select Users from the left pane, under the Users/Departments category.
  • Pick the user who's profile doesn't save.
  • Click the Edit button (represented by a notepad & pencil icon) next to the user name or double click on the user name.
  • Click the Time Off tab under the user's profile.
  • Click Edit Historical Policies in the Paid Time Off section.
  • Click the drop-down next to the Balance category and change the Carry up to value to a positive value or at least 0.
  • Click Save at the bottom.