Symptoms:
The following error message occurs while launching QuickBooks Integration Manager 5.5.5.2, it throws below error message even though online version of QuickBooks is open.

QuickBooks is not open. Please open it and then try again

Cause:
This is most likely happens when ' Web TimeSheet Integration Manager for QuickBooks version 5.5.5.2' unable to recognize online version of QuickBooks as the country version was not selected to USA-Online Edition during the installation process.

Resolution:
In order for Integration Manager to recognize online edition for QuickBooks, uninstall the existing version and reinstall Web TimeSheet integration manager for QuickBooks of version 5.5.5.2 and  choose country version as USA-Online Edition during the installation process.

More Information:
Post installation steps when you launch QuickBooks Integration Manager 5.5.5.2 for the first time:

When you launch QuickBooks Integration Manager after the installation for the first time, click on ‘set up connection!’ button which will give QuickBooks Integration Manager Permission to access online edition of QuickBooks. Create new connection if there isn’t one exist. You will be given a connection ticket when the interview completes that must be pasted in ‘Paste Connection Ticket here:’ field and click ‘OK’.