Symptoms:
Some users may get the following error message when submitting the timesheet,

"There are errors on this Timesheet that will prevent it from being submitted. Please select an Activity."

Cause:
The affected users are not assigned an activity or they do not see an Activity column on their timesheet but have the Show Activities in Timesheet sub-permission for the Timesheet category is set to Activity Selection Required, under one of the permission profiles assigned to these users.

Resolution:
Either verify if the any activities are enabled under the user profile and enable them or ensure that the Show Activities in Timesheet sub-permission for the Timesheet category is set to Activity Selection Not Required.

To verify if the any activities are enabled under the user profile, follow the steps given below:

  • Select Administration from top menu bar.
  • Select Users from the left pane, under the Users/Departments category.
  • From the Users page, click the Edit User button beside the respective user's name.
  • Select the Advanced tab and scroll down to the Activities section.
  • If none of the activities are enabled in this section then put a check mark beside the relevant activities.
  • Click Save.

To ensure that the Show Activities in Timesheet sub-permission for the Timesheet category is set to Activity Selection Not Required, follow the steps given below:

  • Select Administration from top menu bar.
  • Select Permissions from the left pane, under the Users/Departments category.
  • Click the Edit button next to the respective permission profile that is assigned in common to all of the affected users.
  • Expand the Timesheet category.
  • Choose the Activity Selection Not Required drop-down item from the Show Activities in Timesheet sub-permission.
  • Click Save.