Symptoms:
When printing a timesheet or a report from internet explorer 7, 8 or 9 only HTML code gets printed rather than the actual data. The following is an example of the print output,

————————————–

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML__IE_DisplayURL="https://na1.replicon.com/yourcompanyname/main.aspx"><br/>
<HEAD>
<TITLE>Expense Sheet</TITLE>
<META content="IE=8.0000" http-equiv="X-UA-Compatible">
<META content="text/html; charset=utf-8" http-equiv=Content-Type>
<BASE HREF="https://na1.replicon.com/yourcompanyname/main.aspxx#">
<STYLE> HTML { font-family : "Times New Roman" } </STYLE>
<META content=IE=8 http-equiv=X-UA-Compatible>
<BASE href="https://na1.replicon.com/yourcompanyname/main.aspx#">
<LINK title="Default Stylesheet" rel="stylesheet" type="text/css">

————————————–

Cause:
This problem can occur if temporary files (.tmp) are associated with a text editor (such as Notepad). Alternate browsers such as Firefox or Chrome work fine & this issue is not seen.

Resolution:
To get a regular print output, follow the steps given below in the same sequence:

  • STEP 1:
  1. Click on Start > Go to Default Programs > Click Set Program Access and Defaults.
  2. Most likely Custom is selected by default, click the down arrows off to the right to expand the field.
  3. Even if Custom is not selected do the same for the field that is selected.
  4. Under Choose a default web browser, select Internet Explorer.
  5. Click OK. If issue is resolved then skip Step 2 else, proceed to Step 2.
  • STEP 2:
  1. Close any open programs.
  2. Click Start > Run.
  3. Type: regsvr32 /i mshtml.dll.
  4. Press Enter on your keyboard.
  5. Click Start > Run.
  6. Type: regsvr32 /i shdocvw.dll.
  7. Press Enter on your keyboard.

If the problem still persists then one needs to escalate the issue to their internal IT helpdesk  for further technical assistance. Note that this issue will also be seen on other websites and is not specific to Web Timesheet.