Issue:
When timesheet or expense sheet print command is given, the print preview page shows the content; however the printed content is completely blank.
 
Cause:
It is due to the fact that when Internet Explorer-9 is installed, it also installs KB2530548 – Cumulative Security Update for Internet Explorer-9, which corrupts the Internet Explorer-9.
 
Resolution:
To resolve the issue, please follow the steps given below:
  • Click the Pearl Button i.e. (Start button) of Windows Vista or Windows 7, type Programs and Features in the Search box, and then click View installed updates in the left menu.
  • Under Uninstall an update, scroll down to the Microsoft Windows section.
  • Right-click Windows Internet Explorer 9, click Uninstall, and then, when prompted, click Yes.
  • Click one of the following:

    • Restart now (to finish the process of uninstalling Internet Explorer 9, and restore the previous version of Internet Explorer).
    • Restart later (to wait until you shut down or restart your computer).
  • After restarting the system, please visit the web site: https://windows.microsoft.com/en-IN/internet-explorer/downloads/ie-9/worldwide-languages.
  • Select the language you want to install and your version of Windows, and then click Download.
  • Click Run in the File Download dialog box, and then click Continue in the User Account Control dialog box.
  • Once installed restart the computer.
  • After restart, log into Web TimeSheet and then try to print.