Issue:
The following error message occurs during time or expense data transfer from Web TimeSheet to QuickBooks:
"User is not present in QuickBooks"
 
Causes:
The following are some examples to the cause of the issue,
 
  • The order in which employee names are displayed in QuickBooks could be set to display Last Name followed by the First Name. This can be changed in QuickBooks, under the Edit menu at the top menu bar (Edit > Preferences > Payroll & Employees > Display Employee List by First Name).
  • The name of the user in Web TimeSheet matches with the name of the employee in QuickBooks but if the data still doesn't transfer then, the QuickBooks user who currently does the data transfer from Web TimeSheet to QuickBooks doesn't have all of the administrative privileges in QuickBooks.
  • The employee has a middle name in QuickBooks but currently, Web TimeSheet can only store the first and last names of the user, hence if the employee is setup in QuickBooks with a middle name then the QuickBooks Integration Manager will not detect a matching employee name in QuickBooks, during the data transfer and hence the error message.
Solution:
The user name need to be either corrected in Web TimeSheet to match with the employee name in QuickBooks or it could be the other way round, depending on the convenience.
 
More Information:
When data is transferred from Web TimeSheet to QuickBooks, the data is actually recreated in QuickBooks and since the data is being transferred from a third party application (Web TimeSheet) into QuickBooks, the QuickBooks application, as per design, will try to ensure the integrity of its data and allows only users with valid permissions to make changes to QuickBooks.
Because of the confidential data that can be transferred between these two applications, a stringent overview is imperative. Hence, a user with administrative rights on Web TimeSheet can run the integration manager and the same will hold good for QuickBooks. If a third party application is updating QuickBooks, then the user running the data transfer wizard needs to have complete access in the QuickBooks application as an administrator. Its not a limitation but a security enhancement in the QuickBooks application.