Scenario:
Web TimeSheet administrator has full access to Historical Timesheets. When the administrator accesses Historical Timesheets of disabled users, Client, Project/Task and Activity columns are missing from the Timesheet’s. However these columns are visible in the Timesheet list report.

Cause:
This issue is usually caused when the disabled user does not have any seat assignment enabled in the user profile.

Resolution:
Enable a seat assignment in the disabled user’s profile.