Scenario:
When a user accesses timesheet or expense sheet on Mobile App, the Data displayed is out of sync with the data in Web TimeSheet.

Cause:
This usually happens when the app has not updated and the data seen on the app is older than the data in the Web TimeSheet.

Resolution:
If changes were made to timesheets and expense sheets in Web TimeSheet, and the user is not seeing those changes in the mobile app:

  • Ask the user to return to the home page in the app.
  • Ask the user to tap the TimeSheet or Expense icon (depending on which data they want to refresh).
  • This action will cause the app to download any updates from Web TimeSheet (excluding expense sheets that were deleted in Web TimeSheet).

Note:
For changes to other types of data, such as permissions and projects, the data is synced on a schedule.
If the user does not want to wait to see their updated data there are two options:

  • Log out of the app, then log back in. (Manually logging out clears the local database, causing all the data to be downloaded fresh again.)
  • Uninstall and Re-install the Mobile App.

 

Related Items:

What is the Data Sync Schedule for Mobile App with Web TimeSheet?