Scenario:
The time off  does not start to accrue from the start date of the policy. For example: If the policy start date is set to 1st January 2011, the time off is getting accrued from 3rd June 2011.

Cause:
This usually happens if the start date of the user in the user profile is set to a future date (In this case 3rd June 2011).

Resolution:
If the user's start date is wrong correct it, else change the start date of the time off policy.