Scenario:
After updating the Due/End dates under Timesheet setup,the new Due/End dates are not reflecting in the timesheet.

Cause:
When the timesheet is generated, it picks up the due date value as defined in the Due / End dates section. It does not update the value dynamically, if the due date is changed under Timesheet setup.

Resolution:
Delete and re-create the timesheet,  this will ensure that the timesheet picks up the latest due date.