Issue:
When the Administrator executes the API query he gets an error message as shown below.

Cause:
This error comes up because, Can View All System Data is not enabled for the user.

Resolution:
To resolve the issue, please follow the steps given below:

  • Contact the server team and enable Can View All System data for the Administrator
  • Once done, request the user to log out of Web TimeSheet and log back in.
  • Now click on Administration in top menu, and then click Permission in the side menu.
  • Edit the Administrator Permission
  • Expand Integration
  • Make sure that Repliconnect API, API Test Page Access, as well as Can View All System Data is checked.
  • Save the changes and then access the Test Interface under Repliconnect API
  • It should launch the API Request screen