Issue:
While accessing Web Timesheet using the SAML URL we recieve the following error: Server Error in ‘/SAML’ Application Failed to start monitoring changes to ‘C:\Program Files\Replicon Inc\SAML Identity Provider\Bin’ because access is denied.

Cause:
Most likely access to files in the 'bin' folder under SAML identity provider is denied.

Solution:

  • Navigate to SAML identity provider folder.
  • By default, it would be under C:\Program Files\Replicon Inc\SAML Identity Provider.
  • Double click on SAML identity provider, right click on bin folder, and click properties.
  • Select appropriate users under Security, to whom the access should be given under group, make sure full control is selected and then click on Advanced and verify if full control is applied to both folders and sub-folders.

Refer the attachment for error message: