Why is the ‘External User’ name not found in the ‘Client/External Approver’ drop-down in a project?

Symptoms:
Client/External Approver drop-down displays all the external users except the one created recently.

Cause:
This is most likely Client Approver permission wouldn’t be enabled in the external user’s profile.

Resolution:
Enable Client Approver permission in the external user’s profile. To enable Client Approver permission for the External User, follow the steps given below:

  • Log on to Web TimeSheet as the administrator.
  • Click on Administration tab from the top menu.
  • Click on Users under Shortcuts from the side menu.
  • Click on External Users tab.
  • Select the client name to which the user is associated with from the left side pane.
  • Edit the user’s profile.
  • Select Client Approver option permissions under Access tab.
  • Click Save.